Something strange happened to me yesterday in Heroic Slave Pens. I was in the middle of “Totem Duty” on a boss fight when suddenly my Kill Command button seemed to get stuck. You know what a button looks like when you’re pressing it down and using it? It was stuck there.

No biggie, right?

Actually, yes.

See, the Kill Command Bug is a mean, horrible monster. The Kill Command Bug says “NO AUTO SHOT FOR YOU!” and then points and laughs as you cry.

Yes, so long as that Kill Command button looks like that, you cannot Auto Shot no matter how hard you try. You can Arcane. You can Steady. You can Multi. But you don’t fire any Auto Shots. And that, my friends, is Not Good when you’re mid-boss-fight in a Heroic.

Fortunately, amidst my panicking on Ventrilo, my boyfriend picked up Totem Duty for me as I sat there spamming Steady Shot over and over, feeling a bit like a lost and confused kitten. Auto Shot is the solid, unshakable rod that you weave your other shots around, and when it suddenly disappears, the defining aspect of playing a hunter– the shot rotation– just crumbles. It was a horrible feeling.

But then, suddenly! The button got unstuck and everything worked again! Hooray!

I wrote it off as a glitch caused by lag or something and didn’t worry about it. I got some new epic pants and spent basically the last of my gold gemming and armor-kit-ing them and went to bed satisfied.

This morning I went to go farm motes to make up for all the gold I’d spent on my new pants the day before. I figured I’d level a lowbie pet while I was at it; it makes things more interesting.

And then it happened again. The Kill Command button locked up and Auto Shot disappeared. Helplessly I watched my poor level 67 wolf’s health plummet as the level 71 Air Elemental pounded on him; some 40% of my DPS was gone and I couldn’t kill the mob fast enough. Barely he survived that thing. *shudders thinking about it*

This is when I alt+tab’d and turned to Google for help. It turns out the Kill Command Bug isn’t just something that happens to me, it happens to other hunters too. It occasionally happens with other things, like Rapid Fire. And so long as the bug is active, you also cannot feed your pet or log out.

And apparently, currently the only way to fix it is to crit.

So I ran around using Arcane Shot and Multi-Shot and Steady Shot until finally one of them crit. Ding! Auto Shot comes back home to me and everything is fine again.

It didn’t happen again for the rest of that playing session but lemme tell ya, I don’t think I’ll ever be able to look at the Kill Command button the same way again, at least not for a long time. It sits there taunting me. Just waiting to pounce. Just waiting to catch me unawares and pull the Shot Rotation Doormat out from under my feet again.

So what do we know about the Kill Command Bug? We know that Blizzard is aware of the problem although it doesn’t look like it will be fixed until the next patch (it’s in the “issues list” for patch 2.4).

We know that so long as the bug is active you cannot fire Auto Shot, or feed your pet or log out.

We know that the bug is “fixed” if you crit or if you forcibly restart the game (/reloadui does not work. It was one of the first things I tried too.)

It has been suggested that the bug is caused by hitting Kill Command too quickly after your Steady Shot. Guess that’s what I get for making Kill Command a hotkey and honing my reflexes so I pound it basically as soon as I can. =P I suppose I can take the bug as a compliment then?

Until the patch hits, hunters, be on the lookout. The Kill Command Bug could be coming for YOU next, when you least expect it.

Muahahahaha!

*huddles in the corner and whimpers*

9 Responses to “All About: The Kill Command Bug”
  1. lienna says:

    Can’t say I’ve noticed having it myself, perhaps because I have kill command in a rotation macro? Or maybe because I tent to crit a fair amount anyway.

    But what I have noticed a couple of times is a feed pet bug, where it tells em “you don’t know that spell” its in my spell book, but if I try to use it form there it turns into the casting hand and if I select a food it just sits there, mocking me as my pets get less happy and threaten to run away.

    Relogging seemed to work on that, but again reloadui did nothing, and personally I’d really rather not lose my pets after I brought them up from little kittens/baby serpents

  2. Random says:

    I’ve had the same issue, not just with Kill Command. Sometimes my Bestial Wrath/Beast Within gets stuck, and it will cause me to lose auto shots for a while.

    Annoying, especially in raid boss fights. >.<

    Gives those warlocks a chance to catch up =P

  3. Kestrel says:

    Hmm…don’t think I’ve ever seen this, although last night a couple times my Steady/Arcane/!Auto macro wouldn’t fire–but KC looked fine.

    (I also have KC in that macro, but like you, Pike, I also have KC on a separate key that I hit more often than the macro procs it–probably because I’m hitting the dedicated button instead of the macro.) ;)

  4. sonvar says:

    Wow. Thats a relief I thought it was addons causing it. I keep having this happen to me at least once or more a week. Didn’t realize it was bug but I was doing the same you suggested which is plugging away steady/arcane/multi until I got a crit. Thx for the info

  5. Elune's Guidance says:

    [...]except for one part, where, for some reason, auto-shot stopped working. (Which, for Cir (and any other hunter) is an absolute catastrophe.) I reloaded my UI. Nothing. Restarted. Fixed. Gave me such a fright though[...]

    This I made a note of about a month ago, since the problem for me started then. It was only today (as I play my hunter very rarely) that I noticed that, when I critted, my auto-shoot would get unstuck.

    Terrible thing, really… I wish they would fix it soon.

    [ At first I thought that it was due to the macro I made that combined Kill Command with Arcane Shot... ]

  6. Hexapuma says:

    I have had it happen several times… usually when hammering down on viper sting or concussion shot in desperate PVP battles… and let me tell you that when it happens inside a BG you feel very very awkward. My only solution is ALT-F4 and restart WOW… never had a crit unjam it (I think)…

    BTW it seem to happen when you have a slight lag… so I think it has something to do with the queuing of commands.

  7. Caleb says:

    Yeah I’ve had that happen too. I was using a macro that fired off both kill command and steady shot (had to hit it twice if a kill command was ready). I didn’t realize it was a known kill command bug though, figured it was something wrong with the hide ui errors command.

    Thanks for the heads up on that.

  8. Anonymous says:

    raptor strike has been very useful to me to clear this bug up.

  9. Anonymous says:

    lol… for me raptor strike is the one that bugs out…

  10.  
World of Warcraft™ and Blizzard Entertainment® are all trademarks or registered trademarks of Blizzard Entertainment in the United States and/or other countries. These terms and all related materials, logos, and images are copyright © Blizzard Entertainment. This site is in no way associated with Blizzard Entertainment®